Starting on December 6, 2018, you may need to upgrade your PBS Video app. If you are unable to open your app, click here to learn more.

What are the system requirements to view PBS Video content?

  • Supported desktop browsers: Chrome*, Internet Explorer*, Firefox*, Safari* 
  • Mobile devices running: Apple iOS, Android 2.3 and Android 4+ 
  • Support for Flash + HTML5 on desktops (auto-detected), HTML5 on devices 
  • Connection speed: Broadband Required (Minimum bandwidth speed of 500kbps) 

* Latest, or most widely used version.