Starting on December 6, 2018, you may need to upgrade your PBS Video app. Click here to learn more.

Unable to Open Your PBS Video App? You May Need to Upgrade

Starting on December 6, 2018, the PBS Video app requires an upgrade for older devices which are unable to run the app on the device's current version of OS.

This affects a small number of Apple and Android smart phones and tablets using the PBS Video app.

If you are unable to open your PBS Video app starting on December 6, 2018 and your device uses an older OS, your device may be affected. In most cases, your app will freeze when you attempt to open it or may crash to your device's home screen.

If you have encountered problems using your PBS Video app, we recommend checking your smart phone or tablet to see if an update is available for your device. 

Instructions for Updating Apple Devices

Instructions for Updating Android Devices

Once your OS is up-to-date, you can visit your Apple App Store or Google Play Store to update or reinstall the PBS Video app.

Our mobile app supports iOS 9 and higher, Android 4.4.2 (Kit Kat) and higher, and FireOS 4.1.1 and higher.

If your device uses an older OS version and you are unable to update your OS, the PBS Video app will unfortunately be unavailable for your device.