Starting on December 6, 2018, you may need to upgrade your PBS Video app. If you are unable to open your app, click here to learn more.

I am using Firefox and getting an error that I don't have the Flash plugin

You must enable the Flash plugin by clicking the icon in the top left side of the browser and click Allow Now or Allow and Remember.